· 10 years ago · Aug 22, 2016, 03:52 AM
1KEVIN:bin kevin$ ./wso2server.sh -Dsetup
2JAVA_HOME environment variable is set to /Library/Java/JavaVirtualMachines/jdk1.8.0_77.jdk/Contents/Home
3CARBON_HOME environment variable is set to /Users/kevin/Downloads/wso2esb-5.0.0
4Using Java memory options: -Xms256m -Xmx1024m
5[2016-08-22 11:47:59,247] INFO - CarbonCoreActivator Starting WSO2 Carbon...
6[2016-08-22 11:47:59,266] INFO - CarbonCoreActivator Operating System : Mac OS X 10.11.4, x86_64
7[2016-08-22 11:47:59,266] INFO - CarbonCoreActivator Java Home : /Library/Java/JavaVirtualMachines/jdk1.8.0_77.jdk/Contents/Home/jre
8[2016-08-22 11:47:59,267] INFO - CarbonCoreActivator Java Version : 1.8.0_77
9[2016-08-22 11:47:59,267] INFO - CarbonCoreActivator Java VM : Java HotSpot(TM) 64-Bit Server VM 25.77-b03,Oracle Corporation
10[2016-08-22 11:47:59,267] INFO - CarbonCoreActivator Carbon Home : /Users/kevin/Downloads/wso2esb-5.0.0
11[2016-08-22 11:47:59,267] INFO - CarbonCoreActivator Java Temp Dir : /Users/kevin/Downloads/wso2esb-5.0.0/tmp
12[2016-08-22 11:47:59,268] INFO - CarbonCoreActivator User : kevin, en-US, Asia/Manila
13[2016-08-22 11:47:59,501] WARN - ValidationResultPrinter Swap Memory size (MB): 1024 of the system is below the recommended minimum size :2047
14[2016-08-22 11:47:59,502] WARN - ValidationResultPrinter Carbon is configured to use the default keystore (wso2carbon.jks). To maximize security when deploying to a production environment, configure a new keystore with a unique password in the production server profile.
15[2016-08-22 11:48:00,380] INFO - KafkaEventAdapterServiceDS Successfully deployed the Kafka output event adaptor service
16[2016-08-22 11:48:00,616] INFO - ManagementModeConfigurationLoader CEP started in Single node mode
17Mon Aug 22 11:48:06 PHT 2016 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
18[2016-08-22 11:48:08,730] ERROR - Activator Cannot start User Manager Core bundle
19java.lang.Exception: Error in creating the database
20 at org.wso2.carbon.user.core.common.DefaultRealmService.initializeDatabase(DefaultRealmService.java:347)
21 at org.wso2.carbon.user.core.common.DefaultRealmService.<init>(DefaultRealmService.java:89)
22 at org.wso2.carbon.user.core.common.DefaultRealmService.<init>(DefaultRealmService.java:113)
23 at org.wso2.carbon.user.core.internal.Activator.startDeploy(Activator.java:68)
24 at org.wso2.carbon.user.core.internal.BundleCheckActivator.start(BundleCheckActivator.java:61)
25 at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
26 at java.security.AccessController.doPrivileged(Native Method)
27 at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
28 at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
29 at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
30 at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
31 at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
32 at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
33 at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
34 at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
35 at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
36 at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
37 at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
38 at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
39 at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
40Caused by: java.lang.Exception: Error occurred while executing : CREATE TABLE IF NOT EXISTS REG_RESOURCE ( REG_PATH_ID INTEGER NOT NULL, REG_NAME VARCHAR(256), REG_VERSION INTEGER NOT NULL AUTO_INCREMENT, REG_MEDIA_TYPE VARCHAR(500), REG_CREATOR VARCHAR(31) NOT NULL, REG_CREATED_TIME TIMESTAMP NOT NULL DEFAULT 0, REG_LAST_UPDATOR VARCHAR(31), REG_LAST_UPDATED_TIME TIMESTAMP NOT NULL DEFAULT 0, REG_DESCRIPTION VARCHAR(1000), REG_CONTENT_ID INTEGER, REG_TENANT_ID INTEGER DEFAULT 0, REG_UUID VARCHAR(100) NOT NULL, CONSTRAINT PK_REG_RESOURCE PRIMARY KEY(REG_VERSION, REG_TENANT_ID) )ENGINE INNODB
41 at org.wso2.carbon.utils.dbcreator.DatabaseCreator.executeSQL(DatabaseCreator.java:177)
42 at org.wso2.carbon.utils.dbcreator.DatabaseCreator.executeSQLScript(DatabaseCreator.java:333)
43 at org.wso2.carbon.utils.dbcreator.DatabaseCreator.createRegistryDatabase(DatabaseCreator.java:61)
44 at org.wso2.carbon.user.core.common.DefaultRealmService.initializeDatabase(DefaultRealmService.java:337)
45 ... 19 more
46Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Invalid default value for 'REG_CREATED_TIME'
47 at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
48 at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
49 at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
50 at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
51 at com.mysql.jdbc.Util.handleNewInstance(Util.java:404)
52 at com.mysql.jdbc.Util.getInstance(Util.java:387)
53 at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:942)
54 at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3966)
55 at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3902)
56 at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2526)
57 at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2673)
58 at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2545)
59 at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2503)
60 at com.mysql.jdbc.StatementImpl.executeInternal(StatementImpl.java:839)
61 at com.mysql.jdbc.StatementImpl.execute(StatementImpl.java:739)
62 at org.wso2.carbon.utils.dbcreator.DatabaseCreator.executeSQL(DatabaseCreator.java:147)
63 ... 22 more
64[2016-08-22 11:48:30,987] INFO - TaglibUriRule TLD skipped. URI: http://tiles.apache.org/tags-tiles is already defined